1125 Chain the Ropes (25分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2N104​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15
 

Sample Output:

14

思路:贪心,因为越先加进去的被减半的次数会越多,所以让长的绳子尽可能不被对半,先加入短的绳子。


#include<bits/stdc++.h>
using namespace std;
vector<int> ve;
int main(){
    int n;
    cin>>n;
    ve.resize(n);
    for(int i=0; i<n; ++i) cin>>ve[i];
    sort(ve.begin(), ve.end());
    double sum=ve[0];
    for(int i=1; i<n; ++i) sum = (sum+ve[i])/2;
    cout<<floor(sum)<<endl;
    return 0;
}

 

原文链接: https://www.cnblogs.com/LS-Joze/p/13337398.html

欢迎关注

微信关注下方公众号,第一时间获取干货硬货;公众号内回复【pdf】免费获取数百本计算机经典书籍;

也有高质量的技术群,里面有嵌入式、搜广推等BAT大佬

    1125 Chain the Ropes (25分)

原创文章受到原创版权保护。转载请注明出处:https://www.ccppcoding.com/archives/368062

非原创文章文中已经注明原地址,如有侵权,联系删除

关注公众号【高性能架构探索】,第一时间获取最新文章

转载文章受原作者版权保护。转载请注明原作者出处!

(0)
上一篇 2023年3月2日 下午6:12
下一篇 2023年3月2日 下午6:13

相关推荐